Back to overview
Degraded
Degraded application performance
May 18 at 11:46am BST
Affected services
Webapp
Tempo API
Resolved
May 22 at 04:08pm BST
Services have been restored
Affected services
Created
May 18 at 11:46am BST
Performance issues are being investigated, all services are still functional.
Affected services